Account balances not displaying (Profit/Loss, Margin, Equity)
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 05, 2018 - 06:05 UTC
Investigating
We're currently experiencing an issue where some clients are intermittently unable to view their account balance figures (profit/loss, margin and equity). This issue currently affects our mobile and web trading platforms.

This issue is currently being investigated by our IT team.
Posted 10 days ago. Nov 04, 2018 - 23:52 UTC
This incident affected: Web platform and Mobile apps.