MT4 access
Incident Report for IG Index Ltd
Resolved
MT4 service is now operational.
Posted 9 months ago. Mar 06, 2018 - 23:10 UTC
Identified
We have a scheduled maintenance for our MT4 system. Users will be unable to connect for a brief period. Sorry for any inconvenience caused. We will endeavour to get this service back up and available as soon as possible.
Posted 9 months ago. Mar 06, 2018 - 22:33 UTC