Demo account issue
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 10 months ago. Jun 15, 2018 - 13:28 UTC
Investigating
Demo accounts are currently experiencing issues with placing trades. Please be aware this only affects Demo accounts, and does not affect Live accounts.
Posted 10 months ago. Jun 15, 2018 - 06:44 UTC