Issues with MetaTrader 4
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 11, 2017 - 11:33 UTC
Monitoring
MT4 pricing is now working again, and we're monitoring the situation.
Posted about 1 year ago. Dec 11, 2017 - 09:03 UTC
Investigating
There are currently issues with our MetaTrader 4 platform. We're investigating now at the highest priority. If you are unable to deal via the MT4 platform, please call +44 207 896 0079.
Posted about 1 year ago. Dec 11, 2017 - 08:46 UTC