Issues accessing demo accounts
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Sep 16, 2019 - 16:25 UTC
Investigating
Some clients are unable to access their demo account from My IG, we're currently investigating. This does not impact live accounts.
Posted Sep 16, 2019 - 15:08 UTC
This incident affected: Demo accounts.