BT Internet issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 13:42 UTC
Investigating
BT Internet users are currently experiencing broadband connection issues, which may impact connectivity to ProRealTime Charts. Please check the BT Status page for updates on the Broadband issues: https://my.bt.com/consumerFaultTracking/public/faults/tracking.do?pageId=31
Posted Nov 14, 2019 - 12:13 UTC