JSE Delayed Open
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 18, 2018 - 09:02 UTC
Investigating
There is a delayed open on the Johannesburg Stock Exchange (JSE) due to technical issues their side (not IG). Please follow updates on their website: https://www.jse.co.za/services/technologies/market-communications
Posted 6 months ago. Jun 18, 2018 - 07:30 UTC