My IG accounts missing
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 28, 2018 - 12:37 UTC
Investigating
Some accounts are missing from My IG. To workaround this, use the drop-down menu containing your name from the top right of My IG, to choose which account you'd like to access.
Posted 4 months ago. Aug 28, 2018 - 12:31 UTC