Trading issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 01, 2018 - 16:02 UTC
Monitoring
We're continuing to monitor the issue but believe it to be resolved.
Posted 2 months ago. Oct 01, 2018 - 16:02 UTC
Update
We are continuing to investigate issues with trading.
Posted 2 months ago. Oct 01, 2018 - 15:57 UTC
Update
We are continuing to investigate this issue.
Posted 2 months ago. Oct 01, 2018 - 15:53 UTC
Investigating
We're currently investigating issues with trading on our platforms.
Posted 2 months ago. Oct 01, 2018 - 15:49 UTC
This incident affected: Trading.