Virgin media issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 21, 2017 - 19:01 UTC
Identified
Clients using Virgin Media or BT as their ISP may be experiencing problems accessing certain sites such as IG. Please check with Virgin media or BT for current service status.
Posted over 1 year ago. Dec 21, 2017 - 15:23 UTC