Intermittent pricing problem
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 11, 2018 - 19:17 UTC
Investigating
Some clients are experiencing intermittent issues with our platforms and we are currently investigating.
Posted 12 days ago. Sep 11, 2018 - 14:14 UTC