Trading issues reported
Incident Report for IG Index Ltd
Resolved
This incident has been resolved
Posted 8 months ago. Apr 09, 2018 - 00:09 UTC
Monitoring
This issue is now resolved and we're monitoring the situation.
Posted 8 months ago. Apr 08, 2018 - 23:37 UTC
Investigating
We are currently experiencing issues with our indices pricing. We're investigating now at the highest priority. If you need to deal, please call our dealing number +44 207 896 0079 (UK) or +61 (3) 9860 1734 (Australia)
Posted 8 months ago. Apr 08, 2018 - 22:54 UTC