Pricing issues on Germany 30
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 18, 2018 - 16:16 UTC
Investigating
Germany 30 markets are currently set to phone only dealing whilst we investigate a pricing issue. Please call if you need to deal, or check back here for updates.
Posted 3 months ago. Dec 18, 2018 - 16:10 UTC