Issues with MetaTrader 4
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 14, 2018 - 22:58 UTC
Investigating
There are currently issues with our MetaTrader 4 platform. We're investigating now at the highest priority. If you are unable to deal via the MT4 platform, please call +44 207 896 0079.
Posted about 2 months ago. Oct 14, 2018 - 22:22 UTC
This incident affected: MT4.