Frozen pricing on our platform
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 13, 2018 - 13:55 UTC
Monitoring
Issues have now been resolved and we're monitoring now.
Posted 4 months ago. Aug 13, 2018 - 13:53 UTC
Update
We are continuing to investigate this issue.
Posted 4 months ago. Aug 13, 2018 - 13:47 UTC
Update
We are continuing to investigate this issue.
Posted 4 months ago. Aug 13, 2018 - 13:41 UTC
Investigating
We are experiencing problems with frozen prices on our platform. Please call if you need to deal. +44 0207 896 0079
Posted 4 months ago. Aug 13, 2018 - 13:39 UTC
This incident affected: Trading.