Unable to enable/launch ProReal Time on demo accounts
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 12, 2018 - 06:24 UTC
Investigating
We are currently investigating this issue.
Posted 2 months ago. Oct 12, 2018 - 05:41 UTC