Issues trading on ProRealTime charts
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 15, 2018 - 00:18 UTC
Investigating
There are currently issues with trading via ProRealTime charts. We're investigating now at the highest priority. If you need to deal, please use the IG platform or call +44 207 896 0079.
Posted 2 months ago. Oct 14, 2018 - 20:38 UTC
This incident affected: ProRealTime charts.