My IG accounts missing
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 28, 2018 - 07:25 UTC
Identified
Some accounts are missing from My IG. To workaround this, use the drop down menu with your name from the top right, to choose which account you'd like to access.
Posted 4 months ago. Aug 28, 2018 - 07:08 UTC