Card payment issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 07:28 UTC
Monitoring
We've applied a fix and are monitoring the issue.
Posted Apr 24, 2020 - 07:27 UTC
Identified
The issue has been identified and we're applying a fix.
Posted Apr 24, 2020 - 07:24 UTC
Investigating
We're aware that some clients are unable to fund their account online via card. Please bear with us while we investigate the issue.
Posted Apr 24, 2020 - 07:14 UTC
This incident affected: Deposits and withdrawals.