We are continuing to monitor for any further issues.
Posted Mar 24, 2026 - 21:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 14:48 UTC
Identified
Multiple Shares EPICs are showing stale prices on the ProRealTime platform across all regions due to missing live data feeds from IG to PRT. Trading remains unaffected on IG web and mobile platforms, as this issue is specific to ProRealTime. As a workaround the trades can be placed on IG web and mobile platforms.