Intermittent Pricing issues for US shares

Incident Report for IG

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 04:47 UTC

Investigating

We're currently aware of an issue affecting the pricing for our 24 hours US shares offering. This is being investigated as a priority. If you wish to close your position(s), please give us a call at +61 (3) 9860 1734 (AUS), +65 6390 5118 (SG), +44 207 896 0079 (UK), +44 (20) 7633 5431 (International).
Posted Oct 09, 2025 - 03:21 UTC
This incident affected: Trading.