A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 02:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 28, 2025 - 01:32 UTC
Investigating
We're currently experiencing an issue where clients may be seeing stale P&L for total positions. We're investigating this at the highest priority. Individual position P&L is not affected.
Posted Jul 28, 2025 - 00:05 UTC
This incident affected: Web platform and Mobile apps.