We’re aware that some clients experienced an issue earlier with their P&L reflecting closed trades. This has now been resolved, and we apologise for any inconvenience caused. If you're contacting us about a different matter, please continue to hold while we connect you to an agent.
Posted Sep 11, 2025 - 16:46 UTC
Investigating
We're aware that closed trades are not accurately reflected in account balances, they may still appear in open positions and P&L. Please bear with us while we investigate the issue.
Posted Sep 11, 2025 - 16:35 UTC
This incident affected: Web platform, Mobile apps, IG charts, and Trading.