Pricing issue with CME exchange

Incident Report for IG

Resolved

CME Globex FX spot plus markets will pre open at 8.30 central time and open at 9:00 central time.
All day orders and GTDs with today's date will be cancelled. All GTCs that have been acknowledged will remain working.
Posted Nov 28, 2025 - 14:16 UTC

Update

We’re currently monitoring service interruption affecting CME pricing. We're working closely with them to re-establish service as soon as we can and apologise for any inconvenience caused
Posted Nov 28, 2025 - 12:59 UTC

Update

We are continuing to investigate this issue.
Posted Nov 28, 2025 - 05:08 UTC

Investigating

We’re currently monitoring an service interruption affecting CME pricing. Please note, this is a market wide CME exchange caused issue and not IG.

The status of this interruption can be monitored on the CME website: https://www.cmegroup.com/tools-information/cme-global-command-center-system-alerts.html

At this time, we're temporarily unable to take orders for the affected markets.

We will update as soon as we learn more.
Posted Nov 28, 2025 - 04:12 UTC
This incident affected: Trading.