trading issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 03:22 UTC
Investigating
Some clients are experiencing issues trading on our platforms. We're investigating now at the highest priority. If you need to deal, please call +61 (3) 9860 1734 (AU) or +65 6390 5118 (SG)
Posted Jul 07, 2020 - 00:39 UTC
This incident affected: Trading.