Issues logging in to the iPhone app
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 18, 2019 - 17:15 UTC
Investigating
Some clients have reported issues with logging in to the IG Trading iPhone app. We're currently investigating this at a high priority.
Posted 3 months ago. Jul 18, 2019 - 16:21 UTC
This incident affected: Mobile apps.