Issues closing positions
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Sep 11, 2019 - 15:37 UTC
Monitoring
Issues closing positions have now been resolved, and we're monitoring the situation.
Posted Sep 11, 2019 - 14:22 UTC
Investigating
Some clients are experiencing issues closing positions. Please call if you need to deal: 0207 896 0079.
Posted Sep 11, 2019 - 14:09 UTC
This incident affected: Trading.