Issues with card deposits
Incident Report for IG
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 15:18 UTC
Investigating
There are currently issues with card deposits on our platforms and apps. We're investigating now at the highest priority. If you need to fund your account, please use Bank deposits or Paypal linked to bank account (not cards). If you are on margin call please make a bank deposit and submit Proof of Payment for quick allocation or call +44 207 896 0079 if you need to fund immediately.
Posted Jun 13, 2022 - 14:12 UTC
This incident affected: Deposits and withdrawals.