Intermittent issues accessing demo accounts
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 06:02 UTC
Investigating
We are currently investigating an intermittent issue with accessing demo accounts for some clients. This is being looked into by the relevant team. We hope to have this issue resolved as soon as possible.
Posted Jan 06, 2020 - 00:59 UTC
This incident affected: Demo accounts.