Login issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 10:40 UTC
Monitoring
Login issues have now been resolved, and we're monitoring the situation.
Posted Mar 09, 2020 - 08:54 UTC
Investigating
Some clients are experiencing issues logging in to our platforms. We're investigating now at the highest priority. If you need to deal, please call +44 207 896 0079.
Posted Mar 09, 2020 - 08:16 UTC
This incident affected: Web platform and Mobile apps.