Platform outage

Incident Report for IG

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 22:49 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 18, 2025 - 19:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 18, 2025 - 19:16 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 18, 2025 - 19:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 18:57 UTC

Identified

There are currently issues with trading on our platforms. We have identified the issue and working to fix it on priority and we sincerely apologize for the inconvenience caused. Please call us if you need to trade.
Posted Mar 18, 2025 - 18:51 UTC

Investigating

We are currently investigating this issue.
Posted Mar 18, 2025 - 18:41 UTC
This incident affected: Web platform, Mobile apps, IG charts, Trading, Deposits and withdrawals, Login, My IG, Demo accounts, ProRealTime charts, MT4, L2 Dealer, and APIs.