US markets limit up
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 18:49 UTC
Identified
(13/03/2020): Due to market volatility today, US futures and shares (for example Wall Street, S&P 500, NASDAQ, Apple, Microsoft, etc) are at limit up. This means that buying is suspended externally in the underlying market. At IG you will therefore not be able to buy, but only to sell - whether to open or close positions - through phone dealing. HOWEVER, BE WARNED THE PRICE MAY BE SIGNIFICANTLY HIGHER WHEN THE MARKET RE-OPENS.
Posted Mar 13, 2020 - 12:11 UTC