Issues trading on ProRealTime charts
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 20:20 UTC
Investigating
Some clients are experiencing issues trading via ProRealTime charts, and we're currently investigating the issue. Please use the IG platform if you're impacted by the issue, or call +44 207 896 0079 to deal over the phone.
Posted Feb 17, 2020 - 17:38 UTC
This incident affected: ProRealTime charts.