Intermittent issues with pricing on MT4
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 09:15 UTC
Identified
We are currently aware of a pricing issue with MT4. This issue has been escalated to our developers to investigate at the highest priority. We hope to have the issue resolved as soon as possible. If you have any issues editing or closing a position on MT4, please contact us at +61 (3) 9860 1734 (AU), +65 6390 5118 (SG) or +44 (0)20 7896 0079 (UK)
Posted Mar 13, 2020 - 05:26 UTC
This incident affected: MT4.