Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 22:15 UTC
Scheduled
Please note that due to essential maintenance works, dealing will be unavailable between:
10:15 pm on Friday 8 November and 3:00 am on Saturday 9 November.
Account opening will be available from 2:15 am on Saturday.
We apologise for any inconvenience caused
Posted Nov 08, 2024 - 20:39 UTC
This scheduled maintenance affected: Web platform, Mobile apps, IG charts, Trading, Deposits and withdrawals, Login, My IG, Demo accounts, ProRealTime charts, MT4, L2 Dealer, and APIs.