L2 Dealer Login Issue
Incident Report for IG
Resolved
This incident has been resolved.
Posted Nov 07, 2023 - 11:22 UTC
Update
The issue has been resolved
Posted Nov 07, 2023 - 11:21 UTC
Investigating
We have been made aware that some clients are unable to log in to L2 Dealer. We're currently investigating this as a High priority.
Posted Nov 07, 2023 - 08:49 UTC
This incident affected: L2 Dealer.