Reported issues with Trading
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Jul 23, 2019 - 02:58 UTC
Investigating
Some clients have reported issues with trading. This is being investigated with high priority. If you need to edit or close a position. Please contact us at +61 (3) 9860 1734 (Australia) or +65 6390 5118 (Singapore)
Posted Jul 23, 2019 - 02:15 UTC
This incident affected: Trading.