US futures limit down
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 11:12 UTC
Monitoring
All platforms and systems are currently operational. However, please note: due to market volatility today, US futures have triggered their limit-down circuit breakers. This means for markets such as Wall Street, SPX500 and NASDAQ, you may only buy positions, to open or close, through phone dealing. This may continue throughout the afternoon. Please only call to deal if you need to buy to open or close a trade. Otherwise, follow IGSquawk on Twitter for updates, or visit Help & Support for more information on exchange circuit-breakers.
Posted Mar 12, 2020 - 10:03 UTC