Reported issue with DMA trading
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Feb 27, 2019 - 04:02 UTC
Investigating
There has been a reported issue with DMA trading on the trading platform, being unable to place/edit orders. If you are affected, please call in to deal.
We are currently investigating.
Posted Feb 27, 2019 - 00:16 UTC
This incident affected: Web platform, Mobile apps, L2 Dealer, and Trading.