Issues closing positions
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 06, 2019 - 07:57 UTC
Update
All platforms and apps are operational. We're extremely sorry for the issues experienced yesterday, and any difficulty reaching us. We're working tirelessly to answer your queries as soon as possible. If you're still experiencing problems, please call or email, we're here to help.
Posted 14 days ago. Sep 06, 2019 - 07:46 UTC
Update
All platforms and apps are operational. We're extremely sorry for the issues experienced earlier, and any difficulty reaching us. We're working tirelessly to answer your queries as soon as possible. If you're still experiencing problems, please call or email, we're here to help.
Posted 14 days ago. Sep 05, 2019 - 18:44 UTC
Monitoring
We've implemented a fix and are monitoring the issue. Trading should be up and running, but please call us if you continue to experience any issues.
Posted 15 days ago. Sep 05, 2019 - 13:37 UTC
Update
We're continuing to investigate this at the highest priority. Please call us only if you need to close a position. If you experience problems reaching us, please retry and we'll answer your call as soon as possible.
Posted 15 days ago. Sep 05, 2019 - 13:31 UTC
Update
We're continuing to investigate this at the highest priority. Please call us only if you need to close a position. If you experience problems reaching us, please retry and we'll answer your call as soon as possible.
Posted 15 days ago. Sep 05, 2019 - 12:58 UTC
Update
We're continuing to investigate this at the highest priority. Please call us only if you need to close a position. If you experience problems reaching us, please retry and we'll answer your call as soon as possible.
Posted 15 days ago. Sep 05, 2019 - 12:39 UTC
Update
We are continuing to investigate this issue.
Posted 15 days ago. Sep 05, 2019 - 12:19 UTC
Update
We're continuing to investigate this issue, please call only if you need to deal.
Posted 15 days ago. Sep 05, 2019 - 12:00 UTC
Update
We're continuing to investigate this issue, please call only if you need to deal.
Posted 15 days ago. Sep 05, 2019 - 11:53 UTC
Investigating
Some clients are experiencing issues closing positions via our platforms. Please call if you need to deal: 0207 896 0000.
Posted 15 days ago. Sep 05, 2019 - 11:33 UTC
This incident affected: Web platform, Mobile apps, ProRealTime charts, MT4, L2 Dealer, Trading, Deposits and withdrawals, APIs, and Demo accounts.