Issues with payments
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 17:09 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Apr 08, 2020 - 17:07 UTC
Update
We are continuing to investigate the issue with card payments.
Posted Apr 08, 2020 - 16:25 UTC
Investigating
There are currently issues with making card payments on our platforms. We're investigating now at the highest priority.
Posted Apr 08, 2020 - 15:56 UTC
This incident affected: Deposits and withdrawals.