Issues last week
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 11, 2019 - 14:10 UTC
Monitoring
All platforms and apps are operational. We're extremely sorry for the issues experienced last week, and any difficulty reaching us. We're working tirelessly to answer your queries as soon as possible. If you're still experiencing issues on your account, please call or email, we're here to help.
Posted 11 days ago. Sep 09, 2019 - 08:23 UTC