Demo accounts not accessible
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 31, 2019 - 18:05 UTC
Investigating
We're currently investigating an issue with accessing Demo accounts from My IG. This does not affect Live accounts.
Posted 9 months ago. Jan 31, 2019 - 17:15 UTC