Issues with prices on mobile apps
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 07, 2019 - 15:10 UTC
Investigating
Some prices are not showing on the mobile apps. We're investigating at the highest priority.
Posted about 1 month ago. Aug 07, 2019 - 14:44 UTC
This incident affected: Mobile apps.