Issues accessing My IG
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 15:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2020 - 15:44 UTC
Investigating
We're aware some clients are unable to access My IG. The live platform is still up and running as normal. If you need to fund your account, please use the IG Trading mobile app.
Posted Mar 17, 2020 - 14:49 UTC
This incident affected: My IG and Demo accounts.