Trading issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Jun 05, 2020 - 14:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2020 - 14:06 UTC
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 14:05 UTC
Investigating
Some clients are experiencing issues trading on our platforms. We're investigating now at the highest priority. If you need to deal, please call +44 207 896 0079.
Posted Jun 05, 2020 - 14:04 UTC
This incident affected: Trading.