Issues with trading and logging in
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 6 days ago. Aug 13, 2019 - 15:25 UTC
Monitoring
Access to the platform and trading has resumed, we're monitoring the situation.
Posted 6 days ago. Aug 13, 2019 - 14:22 UTC
Update
We're continuing to investigate this issue. If you need to trade, please call our Trading Services team. Otherwise, please monitor this site for updates.
Posted 6 days ago. Aug 13, 2019 - 14:14 UTC
Investigating
Some clients have reported issues with placing trades and logging in to the platform. We're investigating at the highest priority.
Posted 6 days ago. Aug 13, 2019 - 14:04 UTC
This incident affected: Web platform, Mobile apps, Login, and Trading.