MyIG issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 15:11 UTC
Update
We're aware that some clients are still experiencing issues accessing some areas of MyIG. Please continue trying, and call us if you have any issues accessing the platform and need to deal.
Posted Mar 09, 2020 - 14:59 UTC
Investigating
Some clients are experiencing issues logging in to MyIG. We're investigating now at the highest priority. If you need to deal, please call +44 207 896 0079.
Posted Mar 09, 2020 - 14:01 UTC