Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 24, 2025 - 22:00 UTC
Scheduled
Please note that due to essential maintenance works, dealing will be unavailable between:
10:00 pm on Friday, January 24, and 6:00 am on Saturday, January 25.
Payments and account opening will be unavailable in the same period.
We apologise for any inconvenience caused.
Posted Jan 24, 2025 - 21:05 UTC
This scheduled maintenance affected: Web platform, Mobile apps, IG charts, Trading, Deposits and withdrawals, Login, My IG, Demo accounts, ProRealTime charts, MT4, L2 Dealer, and APIs.