Some ASX Shares Pricing Incorrectly
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 31, 2018 - 02:43 UTC
Investigating
A number of ASX shares are showing as closed online and pricing incorrectly.

The issue is under investigation. Please call our dealing line for a quote.
Posted 3 months ago. Dec 30, 2018 - 23:47 UTC
This incident affected: Web platform, Mobile apps, and Trading.